Quantex GmbH
DE RU EN
Your region: Europe

Description of ScanDoc


Terms and Definitions

local version

Local version

Installation package for your chosen operating system (for example, for Windows OS, you need to download and install a file Setup.exe).

This version of the program works directly with the adapter via a Wi-Fi network and does not require a permanent Internet connection.

To register, you need a password for the adapter or an invitation code (Invite code)

Password for adapter

Password for adapter

When you buy a new device, you get a password for the adapter. This password is also an invitation code (Invite code) when registering an account if you have not created it yet. The password is required to bind the adapter to your account or to “untie” it during the sale, as well as to allow other users to access their adapters. The password is saved to the adapter and does not change over time. The password can be read from the adapter in the ScanDoc program.

After registration, you can see the password in the Scandoc program settings.

Invitation Code (Invite Code)

Invitation Code (Invite Code)

Invite Code - the invitation code that you receive when you purchase the device or from other participants www.scandoc.online.
If you bought a new scanner, then the invitation code will match the password that you receive with your scanner.

Password for the Wi-Fi connection of the adapter

Password for the Wi-Fi connection of the adapter

To connect the ScanDoc scanner to a computer or phone via a Wi-Fi network, you must enter the adapter password on Wi-Fi .
The Wi-Fi password is set in the adapter at the factory.

If your scanner has serial number s/n: 01234, then the Wi-Fi connection will be named S1234 , and the password for the Wi-FI connection with the adapter will be scandoc1234 .

Change the password (Network name (SSID)) to the Wi-Fi connection to the scanner


Beginning of work

Brief description before starting work

Create account

To get started, you need to create an account.
An account is also needed to receive the latest updates, firmware, etc.

Account registration procedure

Linking scanners to your account

One or more ScanDoc adapters can be bound to an account.

Updates are received immediately for all adapters that are linked to your account.

Share your scanners with other users

ScanDoc adapters that are linked to your account can be granted access for temporary use to other scandoc.online users who also have an account.

Allowing other users to access your adapter

Unlinking the scanner from your account

When selling your ScanDoc adapter to another user, you need to unlink it from your account (this can be done only in the online version of the program).

Unlinking the scanner from your account


Step 1 - Installing the program on a computer or tablet

Install the software that is included on USB Flash, in accordance with the type and bitness of the operating system, or go to the website quantexlab.com/en/download.html for the latest version of the software.

ScanDoc for Android (minimum version 4.4) can be downloaded from the official Google Play store.

The ScanDoc program for iOs (minimum version 10) can be downloaded from the official TestFlight app.

Step 2 - Register an Account
(If you are already logged in www.scandoc.online, skip this step)

Registration is creating an account. One account for one person or company. You can attach all your devices to your account. It is also needed if you want to use our services.

Create a new account and link a new ScanDoc scanner
  1. Go to quantexlab.com/en/download.html site, download and install ScanDoc for your computer or other device.
  2. Launch the new ScanDoc program on your device (computer, laptop, tablet, phone) using the shortcut on the desktop. (The operating system may ask for permission to access the Internet, allow access.)
  3. Click on the button at the top of the window, an additional side menu will appear.
  4. Click on the "Options" button in the side menu, you will be taken to the program settings window.
  5. Be sure to follow the next step - putting the scanner into download mode
  6. Click on the Registration button.

Switching the scanner to boot mode

This is only necessary if you were working with an old program and now switch to a new program or buy a new scanner.
If you worked in a new program, then skip this step.


Boot mode (latest generation ScanDoc Compact scanner in a short case)

  • Apply power to the scanner (for example, connect it to the diagnostic connector).
  • On the underside of the scanner, you can see the recessed reset button. Press this button with any thin object, hold for 3 seconds, connect the device to the power / diagnostic socket and only then release the button.
  • The device will be switched to boot mode. (the red LED will light dimly). After a while (approximately 30 seconds), the device will communicate.

Boot mode (old ScanDoc in a metal casing)

  • Turn off the scanner
  • Apply power to the scanner (for example, connect it to the diagnostic connector).
  • While holding the "Wi-Fi" button, press the power button.
  • The device will be switched to boot mode. (the red LED will light dimly). After a while (approximately 30 seconds), the device will communicate.

If the adapter did not update for some reason, then you can exit the boot mode by turning off and then turning on the power of the device.

ScanDoc metal housing must be attached to your account. The procedure is described on the documentation page.
Connect to ScanDoc adapter
  1. Connect the ScanDoc Compact to the vehicle's OBDII diagnostic connector.
  2. Connect to the ScanDoc adapter
    For the latest generation ScanDoc Compact in plastic case:
    - via a wireless Wi-FI network on your computer / smartphone using a password.
    If your scanner has serial number s/n: 01234, then the connection will be called S1234, and the password for Wi-Fi connection with it will be scandoc1234
    For ScanDoc in a metal case:
    - via LAN cable
    (make sure you have entered IP address 192.168.1.50 in connection settings)

    wait a little while until the connection is established (approximately 5 seconds).
    Then press the "OK" button
Now disconnect ScanDoc and connect your computer or mobile device to the Internet

Now disconnect from the ScanDoc Wi-Fi network (but do not disconnect the power from the scanner) and connect your computer or mobile device to the Internet, wait a little while the connection is established (about 5 seconds).
Then click "OK" button.
If you have a simultaneous connection to ScanDoc and the Internet, then just press "OK" button.

You will be redirected to the registration page

You will be redirected to the registration page, where the invitation code generated for you will already be entered.

Fill in all the fields and click Registration

To reliably protect your account from hacking, set a unique, complex password. The longer the password, the more reliable it is.

We recommend not using a password that:

  • too simple, for example "12345678";
  • contains your first name, last name, date of birth or phone number.

We recommend using password managers programs.

Login window

A letter will be sent to your e-mail with a request to confirm the registration.

Click the Activate my account button or use the direct link.
You will be redirected to scandoc.online.

Now you are registered in the system.




Step 3 - Get the latest firmware for the adapter

Manual key download
  1. Connect your computer or mobile device to the Internet.
  2. Launch the new ScanDoc program on your device (computer, laptop, tablet, phone) using the shortcut on the desktop. (The operating system may ask for permission to access the Internet, allow access.)
  3. Click the button at the top of the window, an additional side menu will appear.
  4. Click the "Options" button in the side menu, you will be taken to the program settings window.
  5. Click the Get firmware button. (an authorization form will appear, enter your login and password to your account).

The firmware for your scanner will be downloaded from the Quantex server.

Connecting a ScanDoc Scanner
  1. Connect the ScanDoc Compact to the vehicle's OBDII diagnostic connector.
  2. Connect to the ScanDoc adapter
    For the latest generation ScanDoc Compact in plastic case:
    - via a wireless Wi-FI network on your computer/smartphone using a password.
    If your scanner has serial number s/n: 01234, then the connection will be called S1234 and the password for Wi-FI connection with it will be scandoc1234
    For ScanDoc in a metal case:
    - via LAN cable
    (make sure you enter the IP address 192.168.1.50 in the connection settings)

    Then press the "OK " button and wait for a while until the connection is established (about 5 seconds)
Saving Firmware to a Scanner

In the program, press the button Update the firmware on the device

The program will be written to the scanner. The device is now ready for use.


General description

Main window

Main window of ScanDoc program

The program window is conditionally divided into 3 working zones.

  1. Side menu:
    • Select ScanDoc Compact operational adapter;
    • The QNote program;
    • The program for accounting visits QClients;
    • The Support program;
    • The program settings page;
    • Link to documentation and additional materials;
    • Language selection.

  2. Top menu:
  3. Side menu open button.
    Path
    For example:
    Main / Car / SSANGYONG / Actyon sport II (Q150)
    Indicator of the quality of communication between the program and the scanner:
    - stable connection
    - connection is unstable
    - no connection with the scanner
    Link to the download page for the new program.
    Creation of a request for technical support.
  4. Working field

Settings window

Section Options

Run the program installed on your computer or mobile device.

Click the button at the top of the window, an additional side menu will appear.

Click the "Options" button in the side menu, you will be taken to the program settings window.

Consider the items in this window.

User data
(available only in the online version of the program)

User Data Menu

Invite code - Your invitation code, which is stored in your scanner. The invitation code can be subtracted from the scanner during registration. The code is one-time, after the user has registered with it, the code is considered invalid.

Nick name - The name under which you are registered in the system.

E-mail - Your email address.

Current Password - Your current password.

New Password - Enter a new password only if you want to change the current one.

New Password - Repeat the new password again if you change the current one.

To save the current data, click the Save button.

My devices
(available only in the online version of the program)

Menu of available adapters

Title - The arbitrary name of the scanner. In addition to the name, the serial number of this scanner will always be displayed in brackets.

Trusted Users - Enter the space for the user account names that are granted access to this scanner.

Password (Invite code) - Enter the password that the manufacturer provided for this scanner.

To change the data, click Save.

Button Delete device will “detach” this scanner from your account.

If you have forgotten the password for the scanner, click the Send password by E-Mail, button, the password will be sent to your E-mail address that you specified during registration.

To view the list of brands purchased on this scanner, click the Purchased brands

The Buy Now will redirect you to the brand purchase page.

Add adapter
(available only in the online version of the program)

Add New Adapter Menu

Here you can "link" a new scanner to your account. To do this, enter the scanner serial number, password for it and press the Add button.

Adapter menu

An unlimited number of scanners can be linked to your account, switching between them in the side menu.

The scanner with which there is currently a connection is indicated by the icon


Opening of new modules (brands)

The modules are “attached” to the serial number of the adapter and cannot be transferred to another scanner.

After purchasing a new brand from a dealer, you need to update the firmware on the device. If several scanners are attached to your account, then the firmware is downloaded for all your adapters, although new modules may not be open on all scanners.

Opening brands, updating the scanner firmware
  1. Click the button at the top of the window, an additional side menu will appear.
  2. Click the "Options" button in the side menu, you will be taken to the program settings window.
  3. Click the Get firmware button (internet connection required) ,an authorization form will appear, enter your login and password to your account.
  4. Click the Update firmware on the device button (requires a Wi-Fi connection of the scanner)
    The program will be written to the adapter and it will automatically will reboot.
List of purchased brands

To see the list of purchased brands, in the My devices section, click on the adapter serial number link (in the online version of the program, click the Purchased brands button).


Link a new adapter to your account

When you bought a new adapter, you need to attach it to your account (you can do it in the online version of the program only).

Log in to your account at www.scandoc.online by entering your username and password.

Section Options

Click on the button at the top of the window, an additional side menu will appear.

Click on the "Options" button in the side menu, you will be taken to the program settings window.

Go to My devices.

Add user to allowed list
  1. Click the Add device button.

  2. In the Serial number enter the serial number of the new scanner without first zeros
    (in our example, the scanner with serial number 08837, then enter 8837).

  3. In the Password enter the password for this scanner that you received upon purchase.
    If you do not have a password, please contact your dealer.

  4. Click Add

Allowing other users access to your adapter

Another user can work with your adapter over the Internet. Add the user to the trusted list and allow access to the scanner (you can do this in the online version of the program only).

Log in to your account at www.scandoc.online by entering your username and password.

Section Options

Click on the button at the top of the window, an additional side menu will appear.

Click on the "Options" button in the side menu, you will be taken to the program settings window.

Go to My devices.

Add user to allowed list
  1. Click on the adapter serial number
    (In our example, S9789).

  2. In the Trusted users enter the username of the user to whom you want to open access. If there are several users, enter several accounts separated by a space.

  3. In the Password enter the password for this scanner. If you have forgotten the password for the scanner, click the Send password by E-Mail button to receive it by mail.

  4. Click Save button.

In the same way, you can remove the user from the trusted list and deny access to the scanner. Delete username from the list, re-enter the password for the scanner and click Save button.


Work with several adapters

Several adapters can work in one local network (for example, in one room you can work with several adapters at the same time).

To quickly switch between adapters, you need to create shortcuts.

Section Options

Run the local version of the program installed on your computer or mobile device.

Click on the button at the top of the window, an additional side menu will appear.

Click on the "Options" button in the side menu, you will be taken to the program settings window.

Go to Shortcuts for devices.

Adapter shortcut section
  1. Click Add shortcut.

  2. Enter a name for the adapter shortcut. We recommend writing the adapter serial number. Then you will not confuse them.

  3. Enter the IP address of the adapter.

  4. Click Add

Now in the side menu you will see a shortcut to your created adapter.


Work with the program

First, select the car and the system you want to work with. All car brands are divided by region (Europe, America, Asia, etc.).

ECU selection

First of all, you need to choose a car and a system with which you want to work. This can be done in two ways:

1. Select by VIN number

Enter VIN or KBA number
  1. To automatically search for systems in a car, enter its VIN or KBA number in the main window and press Enter.
  2. If it is not possible to enter the VIN number, you can make an automatic search for car blocks, press the button with the magnifying glass .

2. Select manually

Car model selection window in ScanDoc program

You can select the ECU block manually. Left-click on a tile, for example, make, model, vehicle ECU.

System selection window

System selection window in ScanDoc

The system selection window is divided into groups for clarity: engine, chassis, body and multimedia.

You can quickly find the desired ECU unit.

car card

You can also see the car card here.

Here is information about the car, the maximum number of ECU units.

If you got to this window by entering the VIN code on the main page, then the card will also show additional information.

Function buttons that apply to the entire vehicle, not to any specific ECU.

Let's take a closer look at the functions.

Automatic search

Automatic search for ECU blocks

During automatic search, the program tries to connect to all possible ECUs for this car. If the ECU is present, the program reads the identification, codes and DTCs from it.

Sometimes, during auto search, the program may ask you to clarify additional information about the car, for example, what type of air conditioner is installed on the car.

The more ECUs that can be present in the car and the slower the communication protocols with them, the longer the automatic search takes.
List of found ECUs for your car

Blocks of the ECU with which the program could not communicate will be hidden.

You will see a list of found ECU blocks for your car and primary information for analysis.

If the VIN number was read during autosearch or a search was performed by the VIN number of the car, then the program automatically remembers the list of found ECU blocks and saves it to itself. The next time you search for the VIN of the same vehicle, the program will not show the maximum list of ECUs, but the finished search result.

ECU tiles

Tiles are sorted into groups (engine, chassis, body and multimedia), and within groups alphabetically (left to right, top to bottom).

Graphic display of the ECU in the form of a tile

Graphically, ECU blocks are presented in the form of tiles, which consist of:

  1. System icons;
  2. ECU block names;
  3. Additional identification information (VIN, mileage);
  4. Buttons for quickly clearing DTCs;
  5. Indicator for the presence of the configuration change function in the ECU;
  6. DTC error list.
Icon colors

The ECU icon may have several colors depending on the test results:

Red - The ECU was found by auto-search and contains DTC errors
Green - The ECU is found by auto-search and does not contain DTC errors
Gray - The ECU has not yet been searched, or if the ECU remains gray after auto-search, then this means that no DTC information has been read from the ECU)

This is done in order to focus attention on problematic ECU blocks.

Comparison of VIN numbers and mileage in ECU blocks

During autosearch, the program compares VIN numbers from ECU blocks and, if they do not match, then the VIN number is highlighted in red.

The program does not compare mileage, because mileage may vary slightly in different ECU units.

If the DTC has the status "active" or "current" then it is highlighted in red, otherwise it is highlighted in gray.

Update

The function of updating all information on the found ECU blocks

The " update" function differs from autosearch in that it does not try to contact all possible ECUs, but uses a list that was previously prepared by autosearch.

This saves time if it is known for sure that the number of ECUs in the car has not changed since the last visit.

For example: You connected to the car for the first time, performed auto search, saw DTCs, connected to the desired ECU, performed diagnostics. Now you need to put aside the scanner and repair the car. After the repair, you need to diagnose the car again. It makes no sense to re-search for all possible blocks.
To perform a quick update of information on ECU blocks, press the button.

Clearing all DTCs

The function of deleting all DTC errors in the found ECU blocks

The button clears DTC errors in all found blocks.

Usually used to quickly erase DTCs in all ECUs of the car, without having to go into each ECU individually.

Press it, then reread the ECU blocks with the button to control.

Position of the diagnostic socket

The function of deleting all DTC errors in the found ECU blocks

If you press the button, you will see the location of the diagnostic connector in the selected vehicle.

Sometimes the OBD-II connector may be in an unexpected place, such as in the glove compartment.

Sending data to QClients

Sending data to QClients

Using the button , you can save the auto-search data in the QClients accounting program for later analysis, saving or printing.

Fast Print

Quickly print autosearch results

Press the button , the program will send the results of the current autosearch to print.

Quick Print is useful when you want to quickly print out a list of ECUs with DTCs and do not need to save the auto search data.

List of utilities

Quickly print autosearch results

Click on the button , the program will show a list of all available utilities in the car.

To run a utility, click on its name.

This speeds up the work, since you do not need to look for which block contains the required utility. For example, the steering sensor calibration may be in the power steering unit, or it may be in the ABS unit.
Here you see the actual list of utilities that are present in this car, not a list of all possible utilities. This list will also be stored in the program under the vehicle's VIN number. The same car model with the same engines may have different configurations and the software in the ECU units may also support a different list of utilities.
Quickly print autosearch results

The list of utilities can be sorted by name, favorite utilities or by the system in which it is located. To sort, click on the table column heading.

Quickly print autosearch results

If you click on the star icon in the list of utilities, the utility will be added to the list of favorites. In this case, it will appear on the auto search page under the car card. Now the utility can be launched from the autosearch window.

If a utility with the same name is found in another car, it will immediately be displayed on the auto search page.

Clicking the star icon again removes the utility from the list of favorites and from the autosearch page.

Entrance to the ECU

Click on the tile with the name of the ECU block to enter it.

System selection window in ScanDoc

After communication with the electronic control unit (ECU) is established, the program will show the tabs of the diagnostic module.
In different ECU blocks there can be a different number of bookmarks.

The DTC tab shows the number of errors at once.

Depending on the type of ECU or diagnostic protocol, it may take from 0.5 to 15 seconds to start working with the ECU. Some ECUs require more time. This may be due both to the peculiarities of the diagnostic protocol itself, and to the reading of the vehicle configuration by the scanner.
System selection window in ScanDoc

For quick access to bookmarks, access is provided by the keys on the keyboard.
The Esc button on the keyboard corresponds to the Exit button in the program.
The number keys on the keyboard correspond to bookmark numbers. At the bottom of the bookmark, a hint number is displayed for a quick transition.
For example, to switch to the "Error Codes" tab, press the  2  key on the keyboard.

Section "Identification"

ScanDoc identification menu

In the identification section, you can see the passport data of the control unit. This data is necessary to determine the software and hardware version, the calibration version of the control units. The identification data also contains additional information necessary for the correct diagnosis of this control unit.

The program controls the software versions in the ECU and identifiers. If the program encounters an unknown identifier, a corresponding message is displayed. Continuation of work in this case, as a rule, is impossible or limited. In some cases, the user can continue to work, accepting responsibility for the risks.
Tab navigation options

To go to the next bookmark:

  1. Press the Back button and then to another bookmark;
  2. Or click on the bookmarks button at the top.
Bookmark buttons hide on low screen resolution

The bookmark buttons will be hidden if the screen resolution is not enough to display them in one line.

Trouble Codes (DTC) section

The fault codes section displays error codes (DTCs) stored by the electronic control unit, their status and interpretation.

List of Trouble Codes (DTCs)

Most ECUs, in addition to storing the error number, can show the current error status in an additional column. Statuses show additional information on the code. For example, that the code is active or was, but is not available at the moment.

The scanner reads the error code and decodes it. The error can be numbered either by the manufacturer or by the OBD-II standard.

To send a command to clear DTCs from the ECU, press the Clear DTC button

The OBD-II standard also provides for codes defined by the manufacturer. These codes start with P1000.

Errors defined by the OBD-II standard

Symbol Decryption
P P - Engine (Powertrain)
B - Body
C - (Chassis)
U - Communication.
0 0 - Codes defined by OBD-II standard
1 - The codes are defined by the manufacturer.
1 Vehicle system or component code.

Some manufacturer's standards assume only a numerical value for the error.

Freeze frame

Some units support Freeze frame mode. When an error occurs, information about certain parameters is written to the memory of the control unit. This allows you to determine the conditions under which the error occurred. Freeze frame is recorded separately for each error.

If there is a Freeze frame for the error, then the name of the error is displayed in orange font as a link. To obtain information, left-click on the name of the error. Freeze frame will be displayed below the error.

Some ECUs provide multiple Freeze frames for the same error code. Typically, data is stored before, during, and after the occurrence of the DTC.

If there is no decryption for the error code, then you should contact technical support.

Data stream section

Datastream section

In the "Data stream" section, you can view the current information, read, actuators or status data that are requested from the control unit in real time. The parameter has a name, a value, and, if necessary, a unit of measurement.

Parameters, values and units are displayed here.

The list of parameters can be scrolled with your finger or the mouse wheel. At the same time, please note that only the data that you see on the screen is requested from the control unit. And after scrolling, it may take some slight time for the data to appear. This time depends on how fast the control unit can send data.

In ECUs that work according to the ISO-9141, KW71, KW-1284 protocols, each diagnostic parameter is requested by the scanner separately. Each request takes about 0.1 seconds. Therefore, it will take about 1 second to display 10 parameters on the screen. The more parameters that are displayed on the screen, the longer it will take to update the screen.
Opening a Parameter as a Graph

Click on the name of the parameter, you will see the parameter in the form of a graph. If you click again on the name, the parameter will be displayed in digital form. 

Brief description of the graph

In addition to the name and values, the graph shows:

  1. Limits;
  2. Average value;
  3. Minimum and maximum peak values of the visible part of the graph.
Different number of charts on the screen

If there are few charts on the screen, they will be stretched to the full height of the screen. If there are many, then the graphs will be of a fixed size and you can scroll through them.

Datastream control

Stop reading the data stream, set the ruler
  1. Buttons (pause) and (stop) allow you to stop the graph;
  2. After stopping, the measuring ruler becomes available.
    By pressing the left mouse button or finger (for phones and tablets) in the graph field, we can set the ruler to the desired place in the graph;
  3. In this case, this figure will show the value of the parameter at the place where the ruler is established.

The difference between the "pause" button and the "stop" button is that if you continue reading after the pause mode, the previous data will remain, and after the stop button, the graph will be cleared. Pause mode is needed when you want to see a few fast-moving moments in the background of a lot of time. You stopped at some point, and then you know that for a long time you will not have the information you are interested in. Press pause, and before the right moment, start reading again. The graph saves 1000 readings. For a fast-paced schedule, this is approximately 3 minutes of recording.

Start / Stop

By swiping or dragging the graph with the left mouse button held down, you can scroll the graph horizontally.
In stop mode, data is not read from the control unit. To continue reading the parameters, press the button .

+ / -

Buttons (plus) and (minus) - change the time scale.
Each press of the button increases or decreases the time by half. The scale you choose is automatically saved in the program settings. The next time you start the program, the last selected scale will be set.

Graph Display Modes

Automatic vertical scale mode

The first mode is called open entry mode.

This is a mode with automatic vertical scaling. In this mode, the program automatically calculates the scale in such a way that the visible part of the graph occupies the entire space in height, starting from the minimum value of the graph or from the zero line. So, you see the entire range of chart changes in the most detail. This is the main and frequently used mode of working with charts.
But you need to take into account one nuance. Since autozoom constantly adjusts to the current visible values ​​of the graph, you may not see what you expect. Here is an example of recording from wheel sensors during braking. The car stops, the speed graphs go down, and just before the stop, you see that the graph goes up. This can be confusing. This happened because at this moment the scale of the graph has increased, and it already shows a range of very small changes in speed. According to this advice. If you want to watch the current changes slowly, then either set a larger time scale or just pay attention to what range is currently set vertically.

Locked entry mode

The second mode is called Closed Entry Mode.

This is also a mode with automatic vertical scaling. It works in the same way, but unlike the previous one, here the scale is set not from the zero line, but from the minimum to the maximum of the chart. This means that the constant component of the graph is cut out. This mode is needed when you want to see slight fluctuations in the chart against the background of a large constant shift. For example, you want to see fluctuations of a few atmospheres against a constant displacement of a hundred atmospheres.

Mode without autoscale

Third mode. This is normal mode without autoscale.

The graph is shown in the entire possible range of the parameter. The range of the graph change is not always set by the manufacturer, and then the range is taken from the maximum value of the number. These values can be very large, and then you may not see the change in the graph.

Select the display mode depending on the situation.

Automatic vertical scale mode

- button to show all parameters in the form of graphs or digital form.

If there are a lot of parameters, then depending on the power of the computer, there may be a slight delay in response.

Different number of datastream columns

123 - Options for displaying parameters.

You can select 1, 2 or 3 columns. Depending on the screen resolution, these buttons are hidden by
(for example, only one column will be shown on a mobile phone screen).

Parameter selection

Each parameter has a parameter selection checkbox on the left

By setting it we mark the parameters for further work.

  1. Select one or more options;
  2. Click on the selection button ;
  3. Only the selected options will remain on the screen.

Эit is necessary when you want to get the maximum display speed of the parameter and see its fast changes. The more parameters you see on the screen, the slower they appear. Therefore, if you need to watch fast changes, choose fewer parameters.

Another press of the select button returns to normal mode

Deselect all options

The button deselects all parameters.

This is convenient when there are a lot of parameters and you have marked them in different places. And in order not to search for them throughout the list, you can simply click this button.

Deselect all options

The dropdown list is a filter selection.

For more details, see the Working with filters section.

Finding parameters

Search bar.

If you need to show only those parameters in which a specific word or abbreviation is mentioned, for example "DPF", start writing it in the search bar, as you type, parameters will be selected in the name of which the word "DPF" is present.

To cancel the selection of options, delete all text in the search bar.

The selection is carried out by all subtracted parameters, even if they are not shown on the screen.

Additional control buttons

Indicators

Indicators

- indicator button.

Indicators are fixed parameters that are used most often. Indicators are needed for a quick assessment of the main parameters.

Graph Overlay

Selecting Options for the Graph Overlay Mode

- button for chart overlay mode.

This mode is needed to view related parameters. For example when viewing throttle position sensors. This mode is activated when there are checked parameters. The graph can show from one to 4 parameters.

It works like this:

  1. Choose from 1 to 4 parameters;
  2. Click the overlay graph button .
Plot overlay mode
  1. The control buttons work the same as in normal charts;
  2. By clicking on the checkboxes, you can disable or enable the visibility of the parameter;
  3. To exit the overlay mode, press the button again.

Schematic mode

Schematic mode

- the button turns on the "schematic" mode.

The diagram shows which components are installed in the system and the meaning of key parameters.

The scheme for each control block is built automatically based on the names of the parameters that are present in the control block. It is needed so that you can quickly assess what is in the system. For example, how many lambda sensors. Is an air mass meter or intake manifold absolute pressure sensor, etc. installed.

The circuit is also needed in order to quickly find the parameters of these components.

Change the scale of the diagram

To resize the diagram, drag the slider. This is convenient if the circuit is large and few parameters fit on the screen.

The size of the diagram is saved in the browser settings and the next time you open the diagram, it will be the same size as you set last time.

Scheme and indicators can be opened at the same time

In essence, the scheme is a set of filters.

  1. If you press your finger or the left mouse button on a component in the diagram, then the preset filter will turn on and only those parameters that apply to this component will be shown in the data stream.
    For example, let's select the parameters for oxygen sensors;
  2. Filter installed;
  3. The name of the filter is displayed here.

By clicking on the various components of the circuit, we can find the desired parameters. If we want to collect parameters from different systems, then we can mark these parameters by checking the checkboxes.

Reset filter
  1. To reset the filter, press the button
    Resetting filters and resetting flags are not the same thing. Resetting filters does not affect the options you choose;
  2. For example, now, after resetting the filters, you can leave only the marked parameters on the screen by pressing the button .
Highlighting a component for which a DTC is present

If a DTC is stored for a component in the control unit, the component will be highlighted in red flashing.

If you see a system in the diagram that is not really present in the machine, this does not mean an error. Some control units are created as universal for a group of motors. Their set of parameters may contain systems that are not available in a particular motor. 
Chart and indicators can be opened at the same time

The chart and indicators can be opened at the same time.

Chart and indicators can be opened at the same time
  1. Button adds visible data to the QClients database;
  2. The print button generates a report file in a new browser window. All visible parameters will be added to the report. The report can be printed or saved as a PDF.

Working with filters

When you decide to look at some data, you already know exactly what parameters you want to see, but you don't know if they are in this particular ECU.

The set of parameters you want to see depends on the specific situation and the type of fault. For example, if the car does not start, then the probable causes may be: a crankshaft sensor that is not working, an immobilizer blocking the start, or something else. In order to localize the cause, you need to see certain parameters that may be associated with this defect. For example: engine speed, crankshaft timing, injection time, immobilizer status and something else.

On the "data stream" tab, you can filter only the parameters you need by creating your own set of filters. Filter sets are needed to quickly display the parameters you have chosen in advance.

If the car is misfiring, then you need to see RPM parameters, misfire parameters, ignition timing, etc. Thus, for each case, you have a certain set. In order not to look for these parameters every time, for each case, you can add them to the filter once and simply select the desired filter when necessary.

In fact, the filter is your technique, not a set of parameters for a particular block. Using the filter, in two clicks you get a list of the necessary parameters for a particular case.

Basic set of filters

When installing the program, we offer a basic set of filters. We deliberately did not make a complete list, because diagnosticians have individual methods, and it is easier to add to the filter than to remove from it. You can delete them, create your own or edit them. You can do this in the settings.

Create a filter

We recommend that you, before starting all the work, calmly, once, decide which filters you need and create them. You don't have to fill them up right away. Then, during operation, you can enter parameters for troubleshooting by adding them to the desired filter.

Work with filters is carried out in the program settings window.

Filter sets

Click on the button at the top of the window, an additional side menu will appear.

Click on the "Options" button in the side menu, you will be taken to the program settings window.

At the end of the list of settings there will be an item "Filter sets".

To create a new filter, click the Add Filter button.

Editing a filter

The filter editing window will appear:

  1. Filter name (enter a unique name to make it easier for you to search for this filter among others);
  2. List with parameters added to the filter;
  3. General list of all possible parameters;
  4. Remove filter button (if you want to delete the entire filter);
Adding a parameter to a filter

How to quickly create a set of your parameters:

  1. To quickly find a parameter from the general list, enter its name in the search bar of the right table (on the right - a table with all possible parameters);
  2. Select the one you need and check the box on it, now the parameter has appeared in the left table (on the left is the table with the parameters you added);

If you need to remove a parameter from your filter, uncheck this parameter in the left table.

The filter is saved automatically, after editing the list of parameters, just press the button Cancel

Applying a filter

You can apply the filter in the "datastream" tab.

Applying a filter

Above the list of parameters in the data stream, you can see a drop-down list with filters.

Click on the name of a filter to apply it to the current list of options.

If the parameters that are in the filter are not in the current ECU, then the filter name will not appear in the drop-down list.

Applying a filter

If you apply a filter, then only those parameters that are in the filter and are present in the ECU will be displayed.

  1. Select a filter from the list;
  2. To the right of the drop-down list you can see the name of the applied filter;

To cancel the filter and show all parameters from the ECU again, press the (clear filter) button.

Adding parameters to a filter as you work

If in the course of work you saw a parameter that you forgot to add to the filter, then you can quickly add it without interrupting your work.
You can quickly add a parameter only to a previously created filter.

Adding a parameter in the Datastream window

To quickly add a parameter to a previously created filter:

  1. Select one or more of the required options with the checkbox;
  2. Click the button (add to filter);
  3. In the new window, select the filter to which the parameter will be added.

The options you selected will now be in the filter.

Parameters that are the same or close in meaning can be named differently in different control units.
Add parameters to the filter while working and after a while your filter will accumulate all possible combinations of the necessary parameters and you will very rarely add new parameters. Do not worry that the filter has something that is not present in this block. The program will show only those parameters that the filter will contain hundreds of similar parameters. The main thing is that they are needed for this case.

Section "Tests of actuators"

Many control units allow you to temporarily control actuators (injectors, motors, solenoid valves) to check their performance.

Actuator Tests

The list of actuator tests depends on the specific ECU model.

Actuator control

Select an actuator, you can control it using buttons or knobs. Sometimes, for convenience, the current readings of some parameters are displayed. Each actuator is tested in its own way.

Actuator Tests

Often additional parameters need to be monitored. For each test, a filter is provided. If there are parameters for it, then it turns on automatically.

If some parameters are missing, then you can add them yourself:

  1. Select the general list of options;
  2. Select the required one or more parameters;
  3. Click the (add to filter) button. Unlike the data flow, you cannot select a filter because there is only one filter in the test.
There are brands that do not allow you to run tests against the background of data flow. For example, the VAG group, so there will be tests only with the data flow that the manufacturer has provided.

Section "Utilities"

Special Functions

This section contains specialized functions of the ECU, such as adaptations, resets, etc.

Running the utility

Utilities are also launched by clicking on the tile with its name. Read the description carefully, if any, and follow the conditions of the ulilith.

Whatever function you run. The first window will always be informational. Running the test utility or coding will never start the procedure as the first step. Therefore, you can safely run the utility and read its description.

Adaptations

Some components of the vehicle systems, after installing new parts, or periodically, require an adaptation procedure. This can be, for example, teaching the control unit the extreme values of the throttle sensor or the clutch pedal.

Before adapting, it is highly recommended to read the vehicle repair documentation, which describes this procedure.
Reset adaptations

The engine management system adapts to changes in sensor parameters. When installing new spare parts, resetting previously saved corrections is required. To do this, you need to reset the adaptations.

If you are not sure about the function being performed, please refer to the relevant manual before activating it. It must be clearly understood that after resetting the adaptation, with a partially faulty MAF, the engine may not start.
Reset service intervals

It is done when changing the oil. The reset procedure varies from manufacturer to manufacturer. In one case, it may be just one reset button, in the other - programming the run interval until the next warning occurs. For a more detailed description, refer to the vehicle repair documentation.

Section "Configuration"

To reduce the number of ECU options and software options produced, ECU manufacturers make universal blocks that are configured for a specific vehicle configuration.

Actuator Tests

The configuration is also often referred to as coding.

The number of encoding parameters depends on the specific ECU model.

Here you see the name of the parameter, its current state, and the new state that can be changed.

Actuator Tests
  1. To highlight the parameters that you have changed, the program highlights the value in blue if it has been changed;
  2. If the parameter cannot be changed, then there will be no drop-down list. But the current value of the parameter will be shown.
Actuator Tests

In the options there is a "Configuration Data" option. This is the hex code for the entire configuration. When you make a change to the dropdowns, this code also changes. 

Actuator Tests

Change the required parameters and click the Ok button, the scanner will write data to the block.

Additional buttons for working with the configuration:

  • - button displays the history of configuration changes for this vehicle on the screen;
  • - save configuration data button. The configuration will be tied to the machine's VIN and stored in the QClients program;
  • - button to load configuration data from QClients.
With each entry, the configuration is saved automatically and linked to the internal name of the control unit. Once you've made an entry, you can revert back your changes with the button (History of changes).

Work in different versions of the program

You can work either in the old or in the new version of the program. The scanner must have the firmware of the version of the program with which you want to work. Therefore, if you want to upgrade to a different version of the program, you must enter the scanner into download mode and perform a firmware update.

Switching from an old program to a new one

Switching to a new program


If you used to work in the old program and want to switch to the new one, follow these steps:

  1. Enter the scanner into download mode;
  2. Update the firmware in the scanner.

Download Mode


ScanDoc Compact of the latest generation in a short body

  • Power up the device (for example, connect it to the diagnostic socket).
  • On the underside of the scanner, you can see a recessed reset button.
    Press this button with any thin object, such as a paper clip, and hold for 3 seconds.
  • The device will be in the download mode (the red LED will be weakly lit, half glowing). After a while (approximately 30 seconds) the device will communicate.

ScanDoc in a metal case

  • Turn off the device
  • Power up the device (for example, connect it to the diagnostic socket).
  • While holding the Wi-Fi button, press the Power button.
  • The device will be in the download mode (the red LED will be weakly lit, half glowing). After a while (approximately 30 seconds) the device will communicate.

If for some reason the adapter did not update, then you can exit the download mode by turning off and on the power of the device

Now you need to update the firmware on the device.

Updating the Scanner Firmware
  1. Connect the scanner to the computer, click on the button at the top of the window, an additional side menu will appear .
  2. Click on the "Settings" button in the side menu, you will see the program settings window.
  3. Make sure you have internet access.
    Click on the button Download Firmware The software will be downloaded from the server (Internet connection required).
    The program will ask you to enter your credentials: login and password.
  4. Make sure the scanner is connected to Wi-Fi.
    press Update adapter firmware button (requires Wi-Fi network connection scanner)
    The program will be written to the adapter and it will automatically reboot.

Switching from a new program to an old one

Switching from a new program to an old one


If you have previously worked in a new program and want to switch to the old one, follow these steps:

  1. Enter the scanner into download mode;
  2. Update the firmware in the scanner.

Download Mode


ScanDoc Compact of the latest generation in a short case

  • Power up the device (for example, connect it to the diagnostic socket).
  • On the underside of the instrument, you can see a recessed reset button.
    Press this button with any thin object, such as a paper clip, and hold for 3 seconds.
  • The device will be in the download mode (the red LED will be weakly lit, half glowing). After a while (approximately 30 seconds) the device will communicate.

ScanDoc in a metal case

  • Turn off the device
  • Power up the device (for example, connect it to the diagnostic socket).
  • While holding the Wi-Fi button, press the Power button.
  • The device will be in download mode (the red LED will be on at half-glow). After a while (approximately 30 seconds) the device will communicate.

If for some reason the adapter did not update, then you can exit the download mode by turning off and on the power of the device

Now you need to update the firmware on the device.

Connect the scanner to the computer, run the ScanDoc program.

For the latest generation ScanDoc Compact in plastic case:

Updating the scanner firmware in an older version of the program
  1. Open the Options tab;
  2. Make sure the scanner is connected to Wi-Fi. The link indicator will be green;
  3. Press the button Read;
  4. The program reads the serial number from your scanner;
  5. Click on the Get key button (requires program access to the Internet);
  6. Click on the Upload key button. After that, the downloaded firmware with the program will be saved to the adapter and it will automatically reboot.

The scanner is ready to work with the old program!

For ScanDoc in a metal case:

Updating the scanner firmware in an older version of the program.
  1. Open the Options tab;
  2. Make sure the scanner is connected to Wi-Fi. The link indicator will be green;
  3. Press the button Read;
  4. The program reads the serial number from your scanner;
  5. Press the keyboard shortcut Ctrl + Alt + Y.
    The Update the device button will appear in the program window. Click it. After that, the program will be saved to the adapter and it will automatically reboot.

The scanner is ready to work with the old program!